Advertisements

Many of you would have rejoiced when Comex released JailbreakMe 3.0. Not only did it bring what will always be considered the easiest jailbreak possible, but it finally brought an untethered jailbreak to the iPad 2, which had proved a very tough nut to crack.

Cydia Icon

Apple was very quick to release iOS 4.3.4, which plugged the PDF exploit which allowed the jailbreak to occur in the first place under the disguise of "security updates", closely followed by iOS 4.3.5, which addressed additional security (SSL vulnerability) flaws.

What that means is, those of you running 4.3.4, 4.3.3, or indeed any prior versions of iOS 4, you still have security holes which could potentially be taken advantage of by hackers. In order to remedy this, you would theoretically need to upgrade to 4.3.5 to be up-to-date in terms of security.

That just doesn’t work for those enjoying an untethered jailbreak on iOS 4.3.3 or below. Anyone who’s dealt with a tethered jailbreak will know that it takes away the convenience of owning a device that does everything except make toast because it has to be reconnected to a computer every time a reboot is required. Sometimes, the benefits of the jailbreak are outweighed by the annoyance of it being tethered, and many opt to stick with untouched firmware until the next untethered solution is released.

The security issue on pre-4.3.5 devices is an SSL vulnerability known as "CVE-2011-0228", and luckily for those of you that don’t fancy getting caught in the dire straits of tethered jailbreaking, there is a simple solution on hand to fix the issue.

iSSLfix, which is available in Cydia, will bring your device’s security level on par with iOS 4.3.5 without the need to update. It can be found on the BigBoss repo, which you will already have installed on your source list unless you’ve deleted it. You will have to momentarily change your file view settings to Expert if you are currently on Simple in order to locate the file in a search. This can be done by going to Manage > Packages, and tapping the Simple button in the top right-hand corner, which will expose the "Expert" files within Cydia.

iPhone-4-1

Obviously you’ll need to have a jailbroken iPhone, iPad or iPod touch to install iSSLfix from Cydia – You can follow our step by step guide posted here to jailbreak your iPhone, iPad or iPod touch on iOS 4.3.5 using Redsn0w (or PwnageTool), or on iOS 4.3.3 using Redsn0w, PwnageTool, Sn0wbreeze & JailbreakMe (that last one being the easiest).

Alternatively, you can pick up the .deb file and SSH it into your device.

Those running the latest version of iOS 5 Beta will not need this package as it is already patched.

You can follow us on Twitter or join our Facebook fanpage to keep yourself updated on all the latest from Microsoft, Google and Apple.

Advertisements