Ultrasn0w 1.2.3 has been released today to make the unlock compatible with iOS 4.3.3 on iPhone 4 and 3GS, running on the old baseband.

Continue reading... »