With any modern version of iOS, in order to downgrade a device to a previous version of the system, users must have a backed up SHSH blob of the version they’re trying to upgrade/downgrade to, otherwise the process will just fail. This is done to protect devices from vulnerabilities present in earlier versions of iOS but it also stops jailbreakers from applying tweaks that might not be available on the current iOS.

Continue reading... »