Sn0wbreeze has finally been updated to v2.9.7, bringing in support for iOS 6 / iOS 6.0.1 on Pre-A5 powered devices such as the iPhone 4, iPhone 3GS and the 4th-gen iPod touch.

Continue reading... »