Fuzzyband has been upgraded to support the latest baseband 05.13.03 in iPhone OS 4.0 Beta. The following instructions will only help downgrade iPhone 3G which is currently on iPhone OS 4 Beta with 05.13.03 baseband and older bootloader 05.08. This wont work with iPhone 3GS.

Continue reading... »